Author Topic: Thingiverse question  (Read 868 times)

0 Members and 1 Guest are viewing this topic.

GaryHinshaw

  • Global Moderator
  • Crew
  • *
  • Posts: 5990
  • Respect: +1459
Thingiverse question
« on: October 03, 2021, 08:02:49 PM »
+1
I'm trying to find a better way to share design files, rather than posting links directly to TinkerCAD, where the designs are created.  (TinkerCAD links seem to work for some people but not others, and they don't seem to persist, even if they do work at first.)  So I created a Thingiverse account and ported a few test files over, in one case using a direct upload from TinkerCAD to Thingiverse, and in another by uploading an .stl file from my laptop.  So far, I see 2 of the 3 designs I ported rendered on the My Designs page:



The third file is much more complex and it has yet to show up as a thumbnail, but it does seem to exist since my design count at the top of the page is listed as 3.  When I click on a rendered thumbnail it open a page like this:



where the circle in the middle of the pane just spins endlessly (30 mins and still waiting) for a model that renders in seconds in TinkerCAD and in the Photon slicer.  Is this expected behaviour?  Should I be doing something differently, or posting to a different site?  TIA.

John

  • Administrator
  • Crew
  • *****
  • Posts: 11828
  • Gender: Male
  • Respect: +1242
Re: Thingiverse question
« Reply #1 on: October 03, 2021, 08:17:28 PM »
+2
Some days, I think Thingiverse runs on a Commodore 64 .. what you are seeing is normal at times

Sumner

  • Crew
  • *
  • Posts: 65
  • Gender: Male
  • Respect: +51
    • My Home Pages....
Re: Thingiverse question
« Reply #2 on: October 03, 2021, 09:22:05 PM »
+1
Thingiverse can seem to be hit and miss at times as John noted.  Sometimes I post a design and it shows up as an additional design (how yours now shows up as 3 total).  Then I don't see it under my designs but from what I can see others are probably seeing it.  It has been a while but I think I could still find it under 'analytics'.  I'd then go to it there and delete it (if I remember go way down the design to find the delete option).  Then I'd re-post it and I'd now also see it.

Probably not needed if others are seeing it but I like to also see it in case I wanted to edit it.  I think this has happened 3-5 times in over 100 designs that I've uploaded.

I've also found that some of the analytics numbers are not even close to being right, such as the number of downloads.  I think I trust the 'collects' and 'likes' a little more.

Overall though I don't think there is a much better place to post designs so it is what it is.  I have a feeling they never anticipated how big it would get.

Congrats on putting your designs up where others can benefit from them.

Sumner
« Last Edit: October 03, 2021, 09:24:01 PM by Sumner »
Working in N Scale ---Modeling UP from late 40's to early 70's very loosely......

Under$8.00 Servo turnout Control --- 3D Printed Model RR Objects -- My Home Page

http://1fatgmc.com/RailRoad/RR Main/Link Page Menu.html

John

  • Administrator
  • Crew
  • *****
  • Posts: 11828
  • Gender: Male
  • Respect: +1242
Re: Thingiverse question
« Reply #3 on: October 04, 2021, 07:05:33 AM »
0
I can see your page .. but nothing listed as of this morning


GaryHinshaw

  • Global Moderator
  • Crew
  • *
  • Posts: 5990
  • Respect: +1459
Re: Thingiverse question
« Reply #4 on: October 04, 2021, 09:52:18 AM »
0
Right.  I haven't actually Published any of these files yet.  I want to make sure I'm doing things correctly and not uploading files that the system can't handle.  So far I've uploaded 4 files, but I still only see 3 files rendered on my design page:



Not sure what happened to the other one, or how to even delete it, so that my design count matches the number of rendered items.  Also, when I click on one of these thumbnails, I get to a file info page with a larger render pane, but it's hit or miss whether the larger render appears, as opposed to a spinning wheel of death.

So far, I'm not really impressed... Thanks for the responses though, it at least confirms that my experience is not singular.

Sumner

  • Crew
  • *
  • Posts: 65
  • Gender: Male
  • Respect: +51
    • My Home Pages....
Re: Thingiverse question
« Reply #5 on: October 04, 2021, 11:45:48 AM »
0
Go to 'View Analytics'.  If you see the missing design there then click on it and then click on 'Edit'.  Scroll down and you should see 'Delete Thing'.  You should be able to then delete it and re-post it.

When I publish a design and they show the item and the link to it the first thing I do is save the link in my favorites.  Then later or the next day if I go to My Designs and don't see it I have the link to get to it.  Then I'm able to delete and re-post it so that I also see it.  I rarely have to do that.

There are some problems with the site but I'm glad it is there as people frequent it and it is free to use. As I mentioned before having to re-post 3-5 designs of over 100 is something I can deal with.  I'm sure the people that will collect what you contribute will be happy that you posted  :).

I'd go ahead and 'Publish' all of them.  What do you have to lose and it might then be easier for us to help.

Sumner
Working in N Scale ---Modeling UP from late 40's to early 70's very loosely......

Under$8.00 Servo turnout Control --- 3D Printed Model RR Objects -- My Home Page

http://1fatgmc.com/RailRoad/RR Main/Link Page Menu.html

GaryHinshaw

  • Global Moderator
  • Crew
  • *
  • Posts: 5990
  • Respect: +1459
Re: Thingiverse question
« Reply #6 on: October 05, 2021, 06:35:27 PM »
+1
Thanks for the response, and sorry for not replying sooner.

When I look at view analytics, it say I don't have any analytics to view since I haven't published anything yet (which is true).  I'll go ahead and publish the ones that are ready to go shortly, but it looks like the missing design may be forever missing, since I don't know how to get to it to either publish it or delete it.  Oh well, it's not really a big deal, mainly just odd.

Sumner

  • Crew
  • *
  • Posts: 65
  • Gender: Male
  • Respect: +51
    • My Home Pages....
Re: Thingiverse question
« Reply #7 on: October 05, 2021, 07:13:06 PM »
0
That all makes sense.  Yep go ahead and do the publish and post a link here to your designs.  Probably right about never finding the one.  No problem, just post it again.

Sumner
Working in N Scale ---Modeling UP from late 40's to early 70's very loosely......

Under$8.00 Servo turnout Control --- 3D Printed Model RR Objects -- My Home Page

http://1fatgmc.com/RailRoad/RR Main/Link Page Menu.html

GaryHinshaw

  • Global Moderator
  • Crew
  • *
  • Posts: 5990
  • Respect: +1459
Re: Thingiverse question
« Reply #8 on: November 20, 2021, 04:13:34 PM »
0
I'm trying to upload and publish a few items on Thingiverse and would love it if someone could have a look and see if I'm doing it correctly.  Here are two items I published as a test:

H2 dwarf signal head

Trinity 5161 coupler pocket

The former has finished rendering, while the latter is still rendering after more than 2+ hours.  :facepalm:  Are they accessible?  Any tips on what kind of metadata would be helpful?  BTW, is there any way to filter My Designs by those which are already published and those which are not?  It seems the only way is to click through them one by one and see.   :x

I get that it's a free site, but it's pretty lame.

Wutter

  • Crew
  • *
  • Posts: 357
  • Respect: +218
    • Wutter Vehicles and Details
Re: Thingiverse question
« Reply #9 on: November 20, 2021, 04:41:41 PM »
0
The H2 dwarf signal head file downloads and opens correctly.

The Trinity 5161 coupler pocket download button links to a Error 404 page with the file not found.

Is there a reason why you switched over from TinkerCad hosting the files to Thingiverse? The ones on TinkerCad seem to always work correctly without issues.
Alvin
Wutter Vehicles and Details
https://www.shapeways.com/shops/wuttervehicles

Chris333

  • Crew
  • *
  • Posts: 16275
  • Respect: +4059
Re: Thingiverse question
« Reply #10 on: November 20, 2021, 05:07:32 PM »
0
If you get the 404 error. Go to the bottom and there is a box that says "X thing files" click it and boxes will open under it to download each file separately.
« Last Edit: November 20, 2021, 05:49:16 PM by Chris333 »

John

  • Administrator
  • Crew
  • *****
  • Posts: 11828
  • Gender: Male
  • Respect: +1242
Re: Thingiverse question
« Reply #11 on: November 20, 2021, 05:19:52 PM »
0
Both of them downloaded ... although the coupler box didn't render in the preview pane ..

Chris333

  • Crew
  • *
  • Posts: 16275
  • Respect: +4059
Re: Thingiverse question
« Reply #12 on: November 20, 2021, 05:50:08 PM »
0
I have people getting the 404 and the no preview on my stuff as well. I think both are just a processing time thing at Thingiverse.

GaryHinshaw

  • Global Moderator
  • Crew
  • *
  • Posts: 5990
  • Respect: +1459
Re: Thingiverse question
« Reply #13 on: November 21, 2021, 03:03:06 PM »
0
Thanks guys.  I think I'm going to bag it with Thingiverse and just stick to hosting files directly on TinkerCAD for now.  I tried uploading a file 3 separate times and none of them ever rendered, which makes it pretty useless for anyone who's looking for something (not to mention frustrating).  The file is less than a MB and a similar design has rendered there just fine in the past, so it's just glitchy.

The thing that drove me there in the first place was some glitchiness with sharing on TinkerCAD.  I've made some designs public and some have downloaded them just fine, but others seem unable to access them, and/or the links work for a while then go dark.  Further, if I log off now and just look at my list of public files, I see nothing, even though there should be 10 or more different designs that are published.  Is there a difference between making a file public and having it published?

Designing and printing is easy compared to sharing....  :|

https://www.tinkercad.com/users/3CzmFAf8ceH-gary-hinshaw

reinhardtjh

  • Crew
  • *
  • Posts: 2579
  • Respect: +238
Re: Thingiverse question
« Reply #14 on: November 21, 2021, 03:25:18 PM »
0
Thanks guys.  I think I'm going to bag it with Thingiverse and just stick to hosting files directly on TinkerCAD for now.  I tried uploading a file 3 separate times and none of them ever rendered, which makes it pretty useless for anyone who's looking for something (not to mention frustrating).  The file is less than a MB and a similar design has rendered there just fine in the past, so it's just glitchy.

The thing that drove me there in the first place was some glitchiness with sharing on TinkerCAD.  I've made some designs public and some have downloaded them just fine, but others seem unable to access them, and/or the links work for a while then go dark.  Further, if I log off now and just look at my list of public files, I see nothing, even though there should be 10 or more different designs that are published.  Is there a difference between making a file public and having it published?

Designing and printing is easy compared to sharing....  :|

https://www.tinkercad.com/users/3CzmFAf8ceH-gary-hinshaw

That's interesting...  I went to the TinkerCAD link and didn't see anything so I tried to create an account and it's said I had one.  I've never logged into TinkerCAD before.  Turns out it's the same account I have for AutoDesk Fusion 360.  Doh!  :facepalm: Once I signed in I could see 21 different files.
John H. Reinhardt
PRRT&HS #8909
C&O HS #11530
N-Trak #7566