Author Topic: Problem with ESU Nano Pilot STD  (Read 431 times)

0 Members and 1 Guest are viewing this topic.

woodone

  • Crew
  • *
  • Posts: 365
  • Gender: Male
  • Respect: +14
Re: Problem with ESU Nano Pilot STD
« Reply #15 on: May 10, 2019, 04:39:21 PM »
0
Your confused!  :D what about me? I think that is the problem I can’t get the 5.0.5 to run because it tells me it is already running.
Can be fixed I am sure, but I am going to have some hold my hand while getting this fixed.
Thanks for the help so far on this.
I have the loco running OK. Just want to be able to fix this problem now. I am sure it will haunt me sometime in the future.  Might just as well fix now.
Give me a brass locomotive with 6 lights to install with DCC Any day, over hitting keys on a key board!
Anyone up to a phone call?  I will trade DCC install for computer aid. 

peteski

  • Crew
  • *
  • Posts: 20284
  • Gender: Male
  • Respect: +1768
    • Coming (not so) soon...
Re: Problem with ESU Nano Pilot STD
« Reply #16 on: May 10, 2019, 04:52:04 PM »
0
Like Rock mentioned:

1. Reboot your Windows machine (they love to be rebooted).

2. Go to the control panel, progams and features (or whatever it  is called in your version of Windows) and uninstall the LokProgrammer 5. You might want to backup (copy somewhere) all your sound projects (just in case).
 
2. If you still have LokProgrammer 4 still installed, also remove it (same procedure as in step 2 above).

3. Reboot your Windows machine (they love to be rebooted).  Make sure both programs are gone.

4. Do a fresh install of LokProgrammer 4. The serial USB drivers should still be left installed (since that was installed separately)

5. See if LokProgrammer 4 sees the micro decoder properly.

6.  If all is well, do a fresh install of LokProgrammer 5.

7. See if everything still works (you can run either LokProgrammer version as the coexist on your computer).
--- Peteski de Snarkski
--- Honorary Resident Curmudgeon

RAILCAT

  • Crew
  • *
  • Posts: 110
  • Respect: +3
Re: Problem with ESU Nano Pilot STD
« Reply #17 on: May 10, 2019, 05:06:42 PM »
0
That's what I thought too, but someone somewhere (maybe on the Yahoo loksound forum?) said that the hardware gets updated too. Call me confused . . .

The decoder firmware gets updated to the latest version when using the ESU Programmer.

RBrodzinsky

  • Crew
  • *
  • Posts: 759
  • Gender: Male
  • Respect: +226
Re: Problem with ESU Nano Pilot STD
« Reply #18 on: May 10, 2019, 05:52:43 PM »
0
I agree, at this point a reboot of the PC is in order. One can have multiple instances of LP open at the same time, so something else is getting in the program’s way.
Rick Brodzinsky
Chief Engineer - JACALAR Railroad
Silicon Valley FreeMo-N

woodone

  • Crew
  • *
  • Posts: 365
  • Gender: Male
  • Respect: +14
Re: Problem with ESU Nano Pilot STD
« Reply #19 on: May 10, 2019, 06:43:36 PM »
0
Ok, I uninstalled both the 5.0.5 and the 4.0.7  Files - re installed the 5.0.5 only.
The programmer is still telling me it does not support this decoder.
I know the loco is getting power and data has it. Will run with the programmers throttle.
I have not installed the older version 4.o.7. Do,I need that to be reinstalled.
Rebooted after each uninstall.

RBrodzinsky

  • Crew
  • *
  • Posts: 759
  • Gender: Male
  • Respect: +226
Re: Problem with ESU Nano Pilot STD
« Reply #20 on: May 10, 2019, 07:15:15 PM »
0
You don’t have to reinstall 4.7.2, unless you want to. I just suggested it, since we know it worked just fine with the Nano decoders in the past for you.
Rick Brodzinsky
Chief Engineer - JACALAR Railroad
Silicon Valley FreeMo-N

peteski

  • Crew
  • *
  • Posts: 20284
  • Gender: Male
  • Respect: +1768
    • Coming (not so) soon...
Re: Problem with ESU Nano Pilot STD
« Reply #21 on: May 10, 2019, 07:39:41 PM »
0
The decoder firmware gets updated to the latest version when using the ESU Programmer.

No, I was talking about the LokProgrammer interface itself, not decoder.
--- Peteski de Snarkski
--- Honorary Resident Curmudgeon

peteski

  • Crew
  • *
  • Posts: 20284
  • Gender: Male
  • Respect: +1768
    • Coming (not so) soon...
Re: Problem with ESU Nano Pilot STD
« Reply #22 on: May 10, 2019, 07:42:16 PM »
0
Woodone, if LokProgrammer 4 software successfully recognized those decoder (and 6.0.5 does not), then like I said, install the 4.7.2 and try it.  Or am I missing something?  Rick stated that both software versions can coexist.
--- Peteski de Snarkski
--- Honorary Resident Curmudgeon

woodone

  • Crew
  • *
  • Posts: 365
  • Gender: Male
  • Respect: +14
Re: Problem with ESU Nano Pilot STD
« Reply #23 on: May 10, 2019, 08:02:30 PM »
0
When I first found this problem I was using the original 4 software-it was after this I was looking for an updated version- going to put it to bed for awhile until I can get support from ESU.
THANKS  for all the help!
  :D

woodone

  • Crew
  • *
  • Posts: 365
  • Gender: Male
  • Respect: +14
Re: Problem with ESU Nano Pilot STD
« Reply #24 on: May 14, 2019, 02:58:04 PM »
0
Got in touch with ESU this AM.  Was told the decoder was at fault- send in for an replacement.
Going to put the second B unit on the rails today to see if it acts up the same, if it’s bad, might just has we’ll ship 2 at the same time.