Author Topic: Digitrax PR4 reading and writing problems  (Read 413 times)

0 Members and 1 Guest are viewing this topic.

WhitePassRanger

  • Posts: 2
  • Respect: 0
Digitrax PR4 reading and writing problems
« on: October 12, 2018, 10:56:57 PM »
0
Hey everyone,

I'm new to the forum so hopefully I've posted in the correct place.
I have been out of the hobby for over 12 years.

I just had my Digitrax PR4 fail for reading and writing.  I'm using JMRI and I can turn on the throttle and make the Locos function but cannot read or write to the cvs.  I've tried different tracks and different locos with different decoders and no comm!
I'm still new to the DCC so maybe I'm missing something!
I've unloaded and reloaded JMRI, Java, and the drivers for the PR4, no change.
I've tried changing many settings in JMRI, no change.  I've tried Digitrax SoundLoader, no comm to read and write.

My main line is separate from my programming track, so I physically have to move it from track to track.  My main line is running on JMRI via DCC++ because my Zepher from 2005 failed and shows short even when unplugged from the track, and the programming track output crashed years ago, thats why I picked up a PR4.
PR4 worked great with JMRI for multiple decoders reading and writing, this failure is a new development.

Sorry if this is long winded and please help me with any terminology that I have wrong.

Any advise would be great, let me know what questions I can answer!
Thanks in advance!

John

  • Administrator
  • Crew
  • *****
  • Posts: 10969
  • Gender: Male
  • Respect: +598
Re: Digitrax PR4 reading and writing problems
« Reply #1 on: October 13, 2018, 06:45:30 AM »
0
Make sure you set select the programming mode for the PR4 ..

Start here ...  http://jmri.sourceforge.net/help/en/html/hardware/loconet/PR4.shtml  and make sure that it's connected properly




WhitePassRanger

  • Posts: 2
  • Respect: 0
Re: Digitrax PR4 reading and writing problems
« Reply #2 on: October 13, 2018, 03:49:48 PM »
0
I have it wired directly to the programming track that is separate from the main track.  I've got a DCC++ Arduino running my main line.  I have 2 laptops setup, one with the programming track and one with the DCC++, I found switching back and forth on one laptop with both systems sharing the same com port a hassel with constantly changing settings.
I have not changed my wiring setup since it was working, not sure what has changed.

I tried reloading the firmware on the PR4, no change.  It will still run the noise for the engine when the track is powered but will not read or write the cvs.