Author Topic: Help - ESU Loksound SW1 - Motor "Surges" When Stopping or Changing Direction  (Read 274 times)

0 Members and 1 Guest are viewing this topic.

cbroughton67

  • Crew
  • *
  • Posts: 423
  • Gender: Male
  • Respect: +1286
Anyone have an idea what might be happening here? It's a Loksound Select Micro #73800, using three 330uF 16v tantalum caps wired in parallel for a "keep alive." It runs and sounds great, except for this one anomaly that I don't understand. When I bring the locomotive to a stop, it jumps ahead a couple of inches. It sometimes seems to start with a  "jump" as well. I've never seen one do this before, and I have no idea where to begin looking. Help!


Chris Broughton

"Clothes make the man. Naked people have little or no influence on society." - Mark Twain

Steveruger45

  • Crew
  • *
  • Posts: 656
  • Gender: Male
  • Respect: +106
+1
While I have not seen this behavior before on my locos and assuming that there are no mechanical issues with your loco it may be something to do with BEMF settings.  Have you tried doing an auto tune?  If not give that a go.
Steve
Atascocita, Texas

jdcolombo

  • Crew
  • *
  • Posts: 1788
  • Respect: +569
+1
Hi Chris.

First, the obvious stuff.

1.  Is the locomotive selected on another throttle?  This behavior happens when the engine is selected on two throttles.

2.  Are you using the 3-point speed curve or a full 28-step curve (or none at all)?  This behavior also looks like the value in speed step 1 or 2 is higher than speed step 3 - 4.  I used to have a similar problem with TCS Z2's - they wouldn't properly interpolate speed commands between steps 3-4 on a 128-step scale, and they would speed up, then slow down again when going over that specific "hump."  Whatever curve you are using, check to make sure the value in CV2 (on a 3-step curve) or CV's 67-70 (on a 28-step curve) are appropriately linear.  If you're not using a speed curve at all, try setting up a 3-point curve and see if that fixes it.

3.  Do you do the auto-tune routine on the Lok? (Set CV54 = 0, then press F1)?

4.  What kind of throttle/DCC system?

John C.

cbroughton67

  • Crew
  • *
  • Posts: 423
  • Gender: Male
  • Respect: +1286
0
@jdcolombo I use Digitrax, but the video was shot using the LokProgrammer and my laptop - same behavior either way. I tried a decoder reset, checked CV2, 5, and 6. It was using a 3-point speed curve, so I changed it to the 28 point (changed it to "switcher" in the process - love it!), but none of that worked. The cure, it turned out, was using Autotune. After I did that, it works flawlessly. Thank you!


I'm still getting familiar with the LokProgrammer and all of the various settings I have available with it (besides just loading sound files!).


Chris
Chris Broughton

"Clothes make the man. Naked people have little or no influence on society." - Mark Twain

cbroughton67

  • Crew
  • *
  • Posts: 423
  • Gender: Male
  • Respect: +1286
0
While I have not seen this behavior before on my locos and assuming that there are no mechanical issues with your loco it may be something to do with BEMF settings.  Have you tried doing an auto tune?  If not give that a go.


Thanks, @Steveruger45 ! Autotune was the fix!
Chris Broughton

"Clothes make the man. Naked people have little or no influence on society." - Mark Twain

jdcolombo

  • Crew
  • *
  • Posts: 1788
  • Respect: +569
0
Autotune is your friend!

BUT . . . I find that after using Autotune, I often need to reset the value in CV53.  CV53 is the "reference voltage" CV, and I've found that it should be set at about 10 times your track voltage for best engine/throttle response.  The default value, I think, is 140.  In my case, my track voltage is about 12v, so I have CV53 set at 120.  The absolute value is less important than (1) making sure CV53 is the SAME value for all your Lok decoders (otherwise, the engines will respond differently to throttle position) and (2) making sure that the speed curve is "spread out" over the entire throttle.  Here's the description of how to set CV53 from the LokSound V.4 manual (it's the same for the Select):

In CV 53, you set the EMF reference voltage generated by the motor at maximum revs. This parameter may have to be adapted subject to the track voltage and the efficiency of the motor.  If the locomotive reaches maximum speed when the throttle is set to about three-quarter and the top third of the throttle has no influence on the speed, then you should reduce the value of CV 53. Reduce the value by 5 – 8 and test the locomotive again. Repeat this process until the locomotive just reaches its maximum speed when the throttle is fully open.  On the other hand, if the locomotive moves too slowly at full throttle then you should increase the value of CV 53 step by step until the maximum speed is reached.

John C.
« Last Edit: February 17, 2019, 03:14:07 PM by jdcolombo »

cbroughton67

  • Crew
  • *
  • Posts: 423
  • Gender: Male
  • Respect: +1286
0
Autotune is your friend!

BUT . . . I find that after using Autotune, I often need to reset the value in CV53.  CV53 is the "reference voltage" CV, and I've found that it should be set at about 10 times your track voltage for best engine/throttle response.  The default value, I think, is 140.  In my case, my track voltage is about 12v, so I have CV53 set at 120.  The absolute value is less important than (1) making sure CV53 is the SAME value for all your Lok decoders (otherwise, the engines will respond differently to throttle position) and (2) making sure that the speed curve is "spread out" over the entire throttle. 

John C.


That makes sense - probably 140 (14v) for HO, and 120 (12v) for N. I'll have to experiment with it.
Thank again, John.
Chris

Chris Broughton

"Clothes make the man. Naked people have little or no influence on society." - Mark Twain